PHP is amongst the most widely used general-purpose web programming languages. It is quite popular as it’s free software, which can be used to build interactive sites like social networks, online stores or school websites rather than static HTML-based sites. A PHP module must be available on the web server where a PHP website is hosted so that its code can be interpreted. Since there are no license fees for this kind of module and the language provides infinite options for the web-based applications that you set up, there are 100s of millions of PHP websites. On top of that, there are many PHP-based scripts, which you can use for your websites without needing to possess any coding capabilities. Given the fact that there’re a few versions of PHP, you should confirm that the same version that you used whilst setting up your site is present on the web server too.

PHP 4, PHP 5 and PHP 7 Support in Cloud Hosting

With our Linux cloud hosting service, you’ll be able to select the version of PHP that will be active for your shared account, since several versions are available on our servers. With only one mouse click, you’ll be able to switch between PHP 4, 5, 7 and every time a new version is unveiled in the future, we’ll include it in the Hepsia hosting Control Panel without removing the earlier ones. Thus, you’ll be able to host all the websites that you’ve set up throughout the years. In stark contrast with a lot of other web hosts, we will not force you to update such sites, because a script may be outdated, but this doesn’t necessarily mean that it’s vulnerable as you may have implemented modifications to its source code to plug security gaps. For the sake of your convenience, you’ll even be able to select a different version of PHP for each individual site hosted in your account.

PHP 4, PHP 5 and PHP 7 Support in Semi-dedicated Servers

Even in case your websites were built with an older PHP version, you will be able to host them in a semi-dedicated server account from us, as we support different versions running at the same time on our servers and each of them can be enabled for your account with just a click of the mouse via our custom-created Hepsia hosting Control Panel. Besides the most recent PHP 7, we also offer 5.3, 5.2 and the older PHP 4. The latter has already been dropped by most hosting suppliers, but we maintain that you shouldn’t be compelled to modify a site that took several years to build, since older script language syntax doesn’t inevitably equal safety weaknesses. On the contrary, an adequately maintained site using PHP 4 can be more secure than a negligently maintained one using PHP 5. For your convenience, we’ll also give you the opportunity to choose a different PHP version for each individual website within your account.